Sun Dublan
March 2004 Archives 

March 28, 2004

Cisco 827 Config 11:04 PM, 1 Comments

Oh yeah, I was going to post my Cisco 827 config that I use with Qwest's new 1.5M (uncapped) DSL and ArosNet. Here you go. Keep in mind that this is just my configuration. There are many different possibilities that can be just for your setup. There are lots of really good resources out on Cisco's site for lots of different scenarios. I found this document to be quite helpful. The other guides from that section might be helpful, to you, too. Numbers and names have been changed to <bla> to protect the innocent.

There is one thing that I may change for dialer0 that will affect other stuff:

ip address negotiated

to

ip unnumbered Ethernet 0

I would have a hard time doing "overloaded" natting (a.k.a port natting, or masquerading) but would allow me to just use one IP address instead of having the dialer have another IP address. But for now, I'll keep it how it is.

I also have the preliminaries for running a DHCP server on the router, but haven't turned it on yet.

version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 827
!
logging rate-limit console 10 except errors
logging cns-events emergencies
enable secret <bla>
enable password <bla>
!
clock timezone MST -7
clock summer-time MDT recurring
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip domain-name lookup
ip name-server <bla>
ip name-server <bla>
ip name-server <bla>
ip dhcp excluded-address <bla>
!
ip dhcp pool one-ninety-two
network 192.168.0.0 255.255.0.0
default-router 192.168.0.1
dns-server <bla>
domain-name <bla>
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Loopback0
no ip address
!
interface Null0
no ip unreachables
!
interface Ethernet0
ip address 192.168.0.1 255.255.0.0 secondary
ip address <bla>
ip nat inside
no cdp enable
hold-queue 32 in
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
autodetect encapsulation ppp
no cdp enable
ppp pap sent-username <bla> password <bla>
ppp ipcp accept-address
ppp ipcp dns <bla>
!
interface Dialer1
no ip address
shutdown
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
ip nat inside source list 192 interface Dialer0 overload
logging trap debugging
logging facility local4
logging <bla>
access-list 192 permit ip 192.168.0.0 0.0.255.255 any
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
no cdp run
snmp-server community <bla> RO
!
line con 0
exec-timeout 5 0
password <bla>
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password <bla>
login
!
scheduler max-task-time 5000
sntp server <bla>
sntp server <bla>
end

March 27, 2004

Antennas 10:51 PM, 0 Comments

I went to radio shack and bought an antenna and mount for my new house (because we don't think we can afford cable or satellite right now). I climb up my steep roof, with all of the goodies, and I notice that no one has antennas up on their roofs. Anne wasn't excited to be the only one with an antenna on the roof. But I already bought the equipment, and I was already risking my life on the roof, so what the heck, I might as well follow through.

I installed it up there, and it seems pretty sturdy. I wired it up on my patch panel and sent it to the TV's jack, and WOW. Check out that reception! I don't think I've ever had such good reception for an antenna! Heck, this looks better than cable, and I know some people with cable that have a lot worse pictures than this.

Then I hear from my neighbor that he has his antenna in his attic. Hmm. That's a good idea, but now that I have the reception that I have, and the antenna is all installed on the roof, to try it in the attic would be a waste of time, especially if the signal gets degraded with all these reflectors and conductors in there. Besides, this guy, who is an antenna expert, it seems, is on my side, with this:

A lot of people locate antennas in the attic. If you do, consider that all attic wiring, wood and roofing material bcome part of the antenna. The antenna is compromised by its being connected to all this stuff lying nearby. Why would you want to do that? OK. Maybe you are lazy and don't want to put it on the roof. That takes more effort. Also, maybe winter winds would rip apart a consumer antenna. Fine, so long as you know a lot of the value of the antenna is lost by being near other stuff.

I found a neat site here that gives you a good idea of the general direction your antenna should be pointing for where you are. I tried it, and mine shows it should be generally between 202 and 212 degrees from magnetic north. That's pretty neat -- that's about where I estimated it should be when I installed it! No wonders!

March 26, 2004

Safari cached favicons 09:50 AM, 0 Comments

I created a new favicon for a site I was making, and put it in place. All the mozilla-based browsers instantly saw it and updated it, but Safari seemed to never notice it. I couldn't figure out why. I thought it had it cached, but after erasing the history and browser cache (many times) and even resetting safari (supposedly nukes all settings, caches, cookies and what not. "Reset Safari" from Safari pull-down menu) it still didn't see the new icon. It noticed that the icon was gone, however (and showed a generic icon it has for un-iconed sites). But it still didn't show the icon.

So, I thought I'd search for it. I reset safari again and searched for safari stuff in my ~/Library. Interestingly enough, there was a n "Icons" directory under ~/Library/Safari. "Reset Safari" doesn't really reset it all! The icons were still there. I moved the directory over, and found that did it -- it noticed the new icon. But, all my old icons were gone. I needed a better solution.

I moved the directory back and searched for the icon I wanted to delete and deleted them. It worked. Here's how I did it:

find ~/Library/Safari/Icons -type f | xargs grep <domain name>

Looking in the files, that found them. You can remove them with a similar command:

find ~/Library/Safari/Icons -type f | xargs grep -l <domain name> | xargs rm -fv

And away we go!

March 18, 2004

True Cisco DSL 01:10 PM, 0 Comments

So, what was the Cisco 675 and 678? They weren't even Cisco technology, at least I hear. Cisco bought the technology from Netspeed for the deal with (then) USWest. The Netspeed product was called "Homerunner" or something. That explains why the 675 and 678 use a weird operating system that isn't related to cisco products.

That's why I'm excited to get my new Cisco 827 up and running. Knowing Cisco products, it will be more solid and feature rich than the 67x series. Feature rich where it counts, that is. Who needs a web interface to configure a router? Though, it can be a simple webserver for some static files kept in ram if needed. A text-based interface is so much simpler. I should be getting DSL in a couple days to try to get it working. When I get it working, I'll post the configuration here, so I can refer to it if I need it. I've already got it working with NTP and other neat things that Cisco IOS does that the cheap cbos could only dream of doing. Cisco even uses a true-blue Alcatel chip.

If anyone wants a 675, it's available, free of charge :)

10/19/2005 Webmaster: Troy Bowman